Cisco Catalyst 3850 basic configuration for wireless

In the following posts I will try to document what I am learning about the Cisco Catalyst 3850 switch, mostly related to the wireless part of the switch configuration. Maybe some posts will be helpful to someone…

Topology:

3850-lab

The topology is very simple. Two Catalyst 3850 switches in a stack connected to a internal network. And two Cisco 3600 access points connected to the stack.

Basic 3850 switch configuration:

First step is to configure login credentials. These credentials will be used to access also the GUI of the switch:

(config)#username admin privilege 15 secret admin

 

Uplink to another switch in my network:

(config)#interface GigabitEthernet1/0/1
(config-if)#description Trunk-to-SWX
(config-if)#switchport mode trunk
(config-if)#no shutdown

 

Management VLAN configuration:

(config)#vlan 3000
(config-vlan)#name MGMT
(config-vlan)#exit

 

Management interface:

(config)#interface Vlan3000
(config-if)#ip address 172.30.0.115 255.255.254.0
(config-if)#no shutdown

 

When you want to use the 3850 switch as a wireless controller you need to enable the Mobility Controller (MC) functionality the default switch role is Mobility Anchor (MA):

3850-switch(config)#wireless mobility controller
%
Mobility role changed to Mobility Controller.
Please save config and reboot the whole stack.
3850-switch(config)#
*Nov 25 18:59:36.830: (3850-switch-1)
% (3850-switch-1)
Mobility role changed to Mobility Controller. (3850-switch-1)
Please save config and reboot the whole stack. (3850-switch-1)

 

As you see you need to save the configuration and reboot the switch after the MC configuration.

 

After the reboot the wireless management interface needs to be specified. In my case it would be the VLAN 3000 interface.

3850-switch(config)#wireless management interface vlan 3000

 

You can verify your wireless management configuration also from the GUI (http://<switch-management-IP>/wireless) Configuration >>> Controller >>> System >>> Interfaces >>> Wireless Interface

 

screenshot.2114

 

On my switch the default Country Code configured is US:

3850-switch#show wireless country configured
Configured Country.............................: US - United States
Configured Country Codes
US - United States : 802.11a Indoor,Outdoor/ 802.11b / 802.11g

 

I have two access points connected to the switch, but the access points will not associate till I change the country code:

3850-switch#show ap summary
Number of APs: 0
Global AP User Name: Not configured
Global AP Dot1x User Name: Not configured

 

I need to change it to SK:

3850-switch(config)#ap country SK
Changing country code could reset channel and RRM grouping configuration. If running in RRM One-Time mode, reassign channels after this command. Check customized APs for valid channel values after this command.
Are you sure you want to continue? (y/n)[y]: y
% switch-2:wcm:Disable 802.11a and 802.11b networks prior to configuring country code.

 

You see that first I need to disable the 2,4 and 5 GHz interfaces:

3850-switch(config)#ap dot11 24ghz shutdown
3850-switch(config)#ap dot11 5ghz shutdown

 

After this change it is working:

3850-switch(config)#ap country SK
Changing country code could reset channel and RRM grouping configuration. If running in RRM One-Time mode, reassign channels after this command. Check customized APs for valid channel values after this command.
Are you sure you want to continue? (y/n)[y]: y

Ob course the last step is to assign the interfaces to which the APs are connected to the correct VLAN:

3850-switch(config)#interface range Gig 2/0/1 - 2
3850-switch(config-if-range)#switchport mode access
3850-switch(config-if-range)#switchport access vlan 3000

Dont forget to enable the radio interfaces:

3850-switch(config)#no ap dot11 5ghz shutdown
3850-switch(config)#no ap dot11 24ghz shutdown

After this step you can verify the connected APs:

screenshot.2115

Also you can verify this from the GUI using Monitor >>> Wireless:

screenshot.2116

For now it is all that I wanted to do. I will follow this WLAN creation and other settings in the next post.

 

-M-