Cisco Catalyst 3850 wireless configuration

This blog will be about creating some WLANs and testing that client can associate to the WLANs.

 

First I will create two new VLANs on the switch

3850-switch(config)#vlan 100
3850-switch(config-vlan)#name INTERNAL
3850-switch(config-vlan)#exit
3850-switch(config)#vlan 200
3850-switch(config-vlan)#name GUEST
3850-switch(config-vlan)#exit

These new VLANs will be terminated on the 3850 switch therefore I will create also L3 interfaces on the switch that the clients will use as a default gateway.

3850-switch(config)#interface vlan 100
3850-switch(config-if)#description INTERNAL
3850-switch(config-if)#ip address 192.168.100.1 255.255.255.0
3850-switch(config-if)#interface vlan 200
3850-switch(config-if)#description GUESTs 
3850-switch(config-if)#ip address 192.168.200.1 255.255.255.0

IP addresses for the WiFi clients will also be assigned from the 3850 switch:

3850-switch(config)#ip dhcp pool INTERNAL
3850-switch(dhcp-config)#default-router 192.168.100.1
3850-switch(dhcp-config)#dns-server 8.8.8.8
3850-switch(dhcp-config)#exit
3850-switch(config)#ip dhcp pool GUEST 
3850-switch(dhcp-config)#network 192.168.200.0 /24 
3850-switch(dhcp-config)#default-router 192.168.200.1
3850-switch(dhcp-config)#dns-server 8.8.8.8 
3850-switch(dhcp-config)#exit
3850-switch(config)#ip dhcp excluded-address 192.168.100.1
3850-switch(config)#ip dhcp excluded-address 192.168.200.1

Now to the WLAN configuration:

3850-switch(config)#wlan INTERNAL 10 INTERNAL

Here the “”10” is a WLAN identifier, the first “INTERNAL” is the WLAN profile name and the second “INTERNAL” is the SSID.

3850-switch(config-wlan)#broadcast-ssid

Permitting to broadcast the SSID.

3850-switch(config-wlan)#client vlan 100

Associating the WLAN to a VLAN.

3850-switch(config-wlan)#ip dhcp server 172.30.0.115

Configuring the DHCP server. In our case it is the 3850 switch.

3850-switch(config-wlan)#no security wpa akm dot1x 
3850-switch(config-wlan)#security wpa akm psk set-key ascii 0 cisco123

Configuring a preshared key for the INTERNAL WLAN authentication.

3850-switch(config)#wlan INTERNAL 10 INTERNAL
3850-switch(config-wlan)#no shutdown

Dont forget to enable the configured WLAN.

Ok now we can try to connect to the created WLAN. It should work. To verify the client connection use the following commands:

screenshot.2117

screenshot.2118

 

Of course you can verify this also from the 3850 GUI (Monitor >>> Clients):

screenshot.2119

And when you click on the client MAC address:

screenshot.2120

 

Ok next timei I will take a look on the Guest Access configuration.

 

-M-